View Issue Details

IDProjectCategoryView StatusLast Update
0000587SpeedFanS.M.A.R.T.public2008-08-11 12:39
ReporterrobAssigned Toalfredo 
PrioritynormalSeverityfeatureReproducibilityalways
Status resolvedResolutionfixed 
Product Version 
Target VersionFixed in Version4.35 beta 
Summary0000587: Support for Areca RAID Controllers
DescriptionAreca RAID Controllers are supporting Temperature moninoring of all attached harddrives. Probably SMART access for individual drives is also possible.

Should be easily doable, because there exist publicly available API for accessing these features.
API is probably same for all their controllers.

I'm willing to test it if you decide to implement this feature (I'm also Delphi developer, so I'm able to test/debug anything).

Public download of API libraries:
ftp://ftp.areca.com.tw/API/

Conroller we have:
http://www.areca.us/support/index/dc1220.htm

General web:
www.areca.us
TagsNo tags attached.
Motherboard Model
Video Card Model

Relationships

has duplicate 0001016 closedalfredo I would like to be able to add custom software temperature 'sensors' via an API 

Activities

rob

2006-06-22 13:06

reporter   ~0001778

To eliminite confusion:
I just downloaded file ftp://ftp.areca.com.tw/API/Arclib.zip
Unziped it in some temporary folder "arclib".
Then I opened Arclib\help\CArclib.chm without problem.
I can read all topics.
Some example:

CArclib::ArcGetHWMon
The ArcGetHWMon method returns the information about a H/W monitor.



virtual ARC_STATUS ArcGetHWMon (

DWORD HwItem,

pHwMonInfo pHwInfo

);
 

Parameters:
[IN]

HwItem: Hardware monitor item.

 

Value
 Meaning
 
HWMON_FAN_INFO
 Get H/W information about fans.
 
HWMON_VOL_INFO
 Get H/W information about voltages
 
HWMON_TMP_INFO
 Get H/W information about temperatures
 
HWMON_PWR_INFO
 Get H/W information about powers
 
HWMON_UPS_INFO
 Get H/W information about UPS

PS: Probably some small testing application should be created first. Feel free to contact me for cooperation by email or ICQ or Jabber (I will gladly provide you those contacts by email).

alfredo

2006-06-22 13:12

manager   ~0001779

I downloaded the most recent zip.
Does it work for you?

rob

2006-06-22 13:25

reporter   ~0001781

Yes.
I even tried "Arclib_VS2005.zip\Arclib_VS2005\help\CArclib.chm" - it's identical and is working too.

alfredo

2006-06-22 13:34

manager   ~0001782

WOW! Another great performance from Windows XP! I had that CHM on a path deep on a network drive. I tried to copy it to the root of a local filesystem and now I can read it!

rob

2006-06-22 13:34

reporter   ~0001783

You may try to open this:

http://www.exec.cz/public/ArecaDecompiledChm.zip

rob

2006-06-22 13:38

reporter   ~0001784

Nice - Windows are full of surprises :-)

alfredo

2006-06-22 18:24

manager   ~0001785

If you contact me by email we can try to sort this out :-)

gb115b

2006-09-20 11:48

reporter   ~0001999

hey, how's this coming?

gb115b

2007-05-30 00:52

reporter   ~0002558

hi, this feature would be really useful to me, as i have speedfan running on my server in the lounge (to keep the fans quiet) but there's no good way of monitoring the HD temps and adjusting the fans appropriately

alfredo

2008-05-02 14:03

manager   ~0003436

All of you, Areca owners, please, send me an email. Do not contact me using GMAIL, because it blocks zipped exes.

alfredo

2008-08-11 12:39

manager   ~0003960

Full ARECA RAID support is available with the latest beta! Now you can see SMART data for each hard disk connected to ARECA controllers too!

Issue History

Date Modified Username Field Change
2006-06-22 10:11 rob New Issue
2006-06-22 12:50 alfredo Status assigned => acknowledged
2006-06-22 13:06 rob Note Added: 0001778
2006-06-22 13:12 alfredo Note Added: 0001779
2006-06-22 13:25 rob Note Added: 0001781
2006-06-22 13:34 alfredo Note Added: 0001782
2006-06-22 13:34 rob Note Added: 0001783
2006-06-22 13:38 rob Note Added: 0001784
2006-06-22 18:24 alfredo Note Added: 0001785
2006-09-20 11:48 gb115b Note Added: 0001999
2007-05-30 00:52 gb115b Note Added: 0002558
2008-05-02 14:02 alfredo Relationship added has duplicate 0001016
2008-05-02 14:03 alfredo Note Added: 0003436
2008-08-11 12:39 alfredo Note Added: 0003960
2008-08-11 12:39 alfredo Status acknowledged => resolved
2008-08-11 12:39 alfredo Resolution open => fixed
2008-08-11 12:39 alfredo Fixed in Version => 4.35 beta