View Issue Details

IDProjectCategoryView StatusLast Update
0000337SpeedFanUser interfacepublic2008-07-31 17:11
ReporterScottAssigned Toalfredo 
PrioritynormalSeveritymajorReproducibilityalways
Status closedResolutionduplicate 
Platformx86OSWindows XP ProfessionalOS VersionSP-2
Product Version 
Target VersionFixed in Version 
Summary0000337: Events configuration dialog unusable when using 120 DPI
DescriptionOn my system, which uses 1920x1200 resolution at 120 DPI, the Events configuration is unusable, because a substantial part of the form is cut off on the right side.
Steps To Reproduce1. Run 120 DPI.

2. Go to Configure > Events.
TagsNo tags attached.
Motherboard Model
Video Card Model

Relationships

duplicate of 0000567 resolvedalfredo Can't access the right-hand parameter-entry boxes in the Configure>>Event window 

Activities

2005-08-26 02:37

 

cap-002.png (9,090 bytes)
cap-002.png (9,090 bytes)

alfredo

2005-08-31 01:10

manager   ~0001129

I have to admit that "sometimes" Windows drives me crazy. Dialogs should resize automagically according to system metrics and this happens 99% of the times. But... sometimes... it doesn't.
Anyway: the configuration dialog is resizable and it should remember the last size you set.
Can you confirm this?

Scott

2005-08-31 13:07

reporter   ~0001144

The dialog is resizable, and remembers its last size, but even if I enlarge it, the portion I can't see does not become visible. In other words, resizing doesn't help.

alfredo

2005-08-31 13:15

manager   ~0001145

Could you upload a screenshot of an enlarged config dialog so that I can try to figure out what's the problem?
By the way: does the SEND REPORT (INFO tab) dialog show the same issue?

Scott

2005-08-31 13:18

reporter   ~0001146

The screen shot attached here is what it looks like for me--no matter how I size the window. As far as I can tell, the Info dialog does look fine.

2005-08-31 13:19

 

cap-001.png (14,007 bytes)
cap-001.png (14,007 bytes)

Scott

2005-08-31 13:20

reporter   ~0001147

In case it helps, cap-001.png shows an enlarged window.

alfredo

2005-08-31 13:24

manager   ~0001148

Last edited: 2005-08-31 13:31

I see. My guess is that one the default controls from Delphi 7 does not properly handle the resize process with controls anchored to the right side.
I will do my best to find a workaround. It won't be an easy task, but I agree it's upsetting to see it the way you "see" it :-)

alfredo

2005-08-31 13:26

manager   ~0001149

Could you send me an email so that I can send you back a beta?
The email address you will use should be able to receive a 1MB ZIP file containing an EXE.

Scott

2005-08-31 13:37

reporter   ~0001150

I just sent an email to alfredo at almico dot com. I hope that was OK. (I didn't want to post my email address here.)

alfredo

2005-08-31 14:00

manager   ~0001151

You did the right thing. Privacy is always one of my main concerns.

Scott

2005-09-28 20:07

reporter   ~0001244

Did this turn out to be too hard to fix?

Issue History

Date Modified Username Field Change
2005-08-26 02:37 Scott New Issue
2005-08-26 02:37 Scott File Added: cap-002.png
2005-08-31 01:10 alfredo Note Added: 0001129
2005-08-31 01:10 alfredo Status assigned => acknowledged
2005-08-31 13:07 Scott Note Added: 0001144
2005-08-31 13:15 alfredo Note Added: 0001145
2005-08-31 13:18 Scott Note Added: 0001146
2005-08-31 13:19 Scott File Added: cap-001.png
2005-08-31 13:20 Scott Note Added: 0001147
2005-08-31 13:24 alfredo Note Added: 0001148
2005-08-31 13:26 alfredo Note Added: 0001149
2005-08-31 13:31 alfredo Note Edited: 0001148
2005-08-31 13:37 Scott Note Added: 0001150
2005-08-31 14:00 alfredo Note Added: 0001151
2005-09-28 20:07 Scott Note Added: 0001244
2008-07-31 17:11 alfredo Relationship added duplicate of 0000567
2008-07-31 17:11 alfredo Status acknowledged => closed
2008-07-31 17:11 alfredo Resolution open => duplicate