View Issue Details

IDProjectCategoryView StatusLast Update
0002310SpeedFanFan controlpublic2015-01-15 12:12
ReporterStefanJ.Assigned Toalfredo 
PrioritynormalSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
PlatformAsus Z97I-PlusOSWindows 7OS Version 64Bit
Product Version4.50 beta 
Target VersionFixed in Version4.51 beta 
Summary0002310: Speedfan 4.50b2 forgets advanced option of NCT6791D during suspend-resume
DescriptionSpeedfan 4.50b2 ist set to control the fans ("Advanced" -> NCT6791D -> PWM1 to PWM3 mode set to Manual (checked "remember it). "Fan Control" used to determine own profiles.

Everything works well after cold boot. After a suspend-resume cycle the Asus UEFI fan control seems to take over. Checking "Advanced" -> NCT6791D tells for all "PWMx modes" tell me "DO NOT USE". Changing back to "Manual" does not work. A reboot fixes the situtation.

Feel free to contact me for further information or debug files. I appreciate your outstanding work. For me Speedfan support is vital before I buy new mainboards.
Steps To ReproduceSet "Advanced" -> NCT6791D -> PWM x mode to "Manual" (remember it)

Make own profiles in "Fan Control" --> Works well

Goto to suspend mode

Wake computer --> Fan control via Speedfan is broken, Asus fan control kicked in

Check "Advanced" -> NCT6791D --> PWM x mode is set to "DO NOT USE"
TagsNo tags attached.
Motherboard ModelAsus Z97I-Plus
Video Card ModelAsus Geforce 670 DC2

Relationships

has duplicate 0002349 closedalfredo Speedfan loses speed control after entering and waking from sleep 

Activities

StefanJ.

2014-10-03 11:20

reporter  

Before Standby.PNG (43,095 bytes)
Before Standby.PNG (43,095 bytes)

StefanJ.

2014-10-03 11:20

reporter  

After Resume.PNG (44,138 bytes)
After Resume.PNG (44,138 bytes)

alfredo

2014-10-20 10:59

manager   ~0007602

I think the BIOS, or some other tool, is aggressively resetting those registers. SpeedFan reapplies advanced settings after resume. Now I need to understand what is applying a further change after SpeedFan.
Can you send me a SEND REPORT from SpeedFan's INFO tab after a resume from suspend? Thank you.

StefanJ.

2014-10-20 16:28

reporter   ~0007605

Last edited: 2014-10-20 16:30

View 2 revisions

Report sent. I am with you with your assumption that the registers seems to be overwritten by -most certainly- bios. Bios fan control is in charge after resume - fans react to higher workload but speedfan control is not working. Manual exiting of speedfan and restarting speedfan leads to again working fan control by speedfan.
I try to monitor bugtracking frequently to assist in short time.

zaluper

2014-12-16 20:21

reporter   ~0007657

just add the speed fun reinitialization option on pc wake up/resume in the next build. and it would be cool to add custom fan profiles to an app!:)

for now I added a task that restarts the speed fan on wake up and it solved the problem...

alfredo

2015-01-15 12:11

manager   ~0007678

This issue has been fixed in the latest private beta.

Issue History

Date Modified Username Field Change
2014-10-02 18:56 StefanJ. New Issue
2014-10-02 18:56 StefanJ. Status new => assigned
2014-10-02 18:56 StefanJ. Assigned To => alfredo
2014-10-03 11:20 StefanJ. File Added: Before Standby.PNG
2014-10-03 11:20 StefanJ. File Added: After Resume.PNG
2014-10-20 10:59 alfredo Note Added: 0007602
2014-10-20 10:59 alfredo Status assigned => acknowledged
2014-10-20 16:28 StefanJ. Note Added: 0007605
2014-10-20 16:30 StefanJ. Note Edited: 0007605 View Revisions
2014-12-16 20:21 zaluper Note Added: 0007657
2015-01-14 23:00 alfredo Summary Speedfan 4.50b2 forgets advanced option of NCT4791D during suspend-resume => Speedfan 4.50b2 forgets advanced option of NCT6791D during suspend-resume
2015-01-15 12:11 alfredo Note Added: 0007678
2015-01-15 12:11 alfredo Resolution open => fixed
2015-01-15 12:11 alfredo Fixed in Version => 4.51 beta
2015-01-15 12:12 alfredo Status acknowledged => resolved
2015-01-15 12:12 alfredo Relationship added has duplicate 0002349
2016-12-21 20:01 09876ggddzz Issue cloned: 0002584