View Issue Details

IDProjectCategoryView StatusLast Update
0000008SpeedFanHardware supportpublic2018-08-14 04:40
ReporterRogaczAssigned Toalfredo 
PrioritynormalSeveritymajorReproducibilityalways
Status closedResolutionduplicate 
PlatformPCOSWindows XPOS VersionSP1
Product Version4.12 
Target VersionFixed in Version 
Summary0000008: Program initialization crashes internal monitor settings
DescriptionWhen I run SpeedFan, my monitor settings are resetted to default after full set up of program. It`s very annoying and it occurs every time I start this program.
Steps To ReproduceI found that accesing advenced GF FX options or changing resolution to 800x600 and then back to 1024x768 restores propper screen settings, but when I exit program, and run it once more time, screen is going smaller and sunken.
Additional InformationThat`s what SpeedFan detects:

Found nVidia GeForce FX 5600 Ultra
Scanning ISA BUS at $0290...
IT8712F/IT8705F found on ISA at $290
SuperIO Chip=IT8712F
Scanning VIA SMBus at $E800...
Scanning I2CNVidia SMBus at $3D403E3F...
DDC MONITOR found at $50
Scanning I2CNVidia SMBus at $3D403637...
Scanning I2CNVidia SMBus at $3D405051...
MAX6648 (ID=$59) found on SMBus at $4C
SMART Enabled for drive 0
Found ST380011A (80,0GB)
TagsNo tags attached.
Motherboard Modelmsi x370 gaming pro carbon
Video Card ModelLeadtek A310 Ultra (GF FX 5600 Ultra)

Relationships

duplicate of 0000003 closedalfredo Speedfan change my monitor settings 

Activities

alfredo

2004-06-14 14:54

manager   ~0000016

Please, drop me an email so that I can send to you a new beta to see if it fixes this issue.

alfredo

2004-06-14 15:18

manager   ~0000017

Did you receive the beta I just sent to you?
Unfortunately, there is a virus swarm these days and email doesn't seem to be that relialable :-(

Rogacz

2004-06-14 16:24

reporter   ~0000018

Last edited: 2004-06-14 16:26

I reccieved this fix, and it doasn`t do anything.

edited on: 06-14-04 16:26

almico

2004-06-14 16:28

administrator   ~0000019

Ooops... I just sent the beta to you to the alternate email address.
What do you mean with "it doesn't do anything"? Do you mean that the startup process goes flawlessly and that your monitor no longer loses its settings?

Rogacz

2004-06-14 16:54

reporter   ~0000020

I meant that this fix You`ve sent doasn`t fixed my problem ;)

It`s just like before, my display still loses my settings.

Btw. thanks for fast respond.

almico

2004-06-14 17:45

administrator   ~0000022

After program startup you should find a DEBUG.NFO file in SpeedFan's directory. Could upload it here, please?

2004-06-14 18:55

 

debug.zip (2,048 bytes)

Rogacz

2004-06-14 18:55

reporter   ~0000023

Uploaded.

Rogacz

2004-06-14 19:06

reporter   ~0000025

<SMBus12CNVidia@$3D403E3F> address $0037

That causes the problem.

Next debug comming shortly.

2004-06-14 19:06

 

debug2.zip (2,293 bytes)

almico

2004-06-14 19:57

administrator   ~0000026

Thank you! I'm going to investigate :-)

Rogacz

2004-06-14 20:04

reporter   ~0000027

No. Thank You! :>

Rogacz

2004-06-14 20:06

reporter   ~0000028

Oh by the way, maybe some of my drivers are responsible for this. For graphics I`m using StarStorm drivers instead of original nVidia ones (they are modified original ones). Or maybe it`s Bios issue? (A7V8X-X on VIA KT400 @ newest 1010 release).

almico

2004-06-14 20:14

administrator   ~0000029

I'm working on this. Currently I've got two options:
1) remove detection of something basically not that usefull
2) try to insert a delay before every check
I'm considering the latter: it would increase startup time by only a few seconds :-)

Rogacz

2004-06-14 21:00

reporter   ~0000030

Will delaying fix it?

almico

2004-06-14 21:06

administrator   ~0000031

I sent to you a new beta 20 minutes ago. Did you receive it?
I don't think delaying will fix it as, basically, you already added a delay when, with the previous beta, you had to press a key. I would have inserted something like a 2 secs delay.

almico

2004-06-14 22:02

administrator   ~0000032

I just sent to you "4.13 beta 12".
This version greatly improves support for your video card. I would like to know if you still experience the issue with this latest beta.
Thank you!

alfredo

2004-06-17 10:47

manager   ~0000043

Version 4.13 will improve nVidia Video Card support, remove some checks for odd hardware devices and completely remove nVidia Video Card I2C scanning in SEND REPORT.
This way there is no known way to hurt the monitor via SpeedFan.

Issue History

Date Modified Username Field Change
2004-06-14 14:31 Rogacz New Issue
2004-06-14 14:31 Rogacz Video Card Model => Leadtek A310 Ultra (GF FX 5600 Ultra)
2004-06-14 14:48 alfredo Status assigned => acknowledged
2004-06-14 14:49 alfredo Relationship added duplicate of 0000003
2004-06-14 14:49 alfredo Resolution open => duplicate
2004-06-14 14:54 alfredo Note Added: 0000016
2004-06-14 14:54 alfredo Note View State: 16: public
2004-06-14 15:18 alfredo Note Added: 0000017
2004-06-14 16:24 Rogacz Note Added: 0000018
2004-06-14 16:24 Rogacz Note Edited: 0000018
2004-06-14 16:26 Rogacz Note Edited: 0000018
2004-06-14 16:28 almico Note Added: 0000019
2004-06-14 16:54 Rogacz Note Added: 0000020
2004-06-14 17:45 almico Note Added: 0000022
2004-06-14 18:55 Rogacz File Added: debug.zip
2004-06-14 18:55 Rogacz Note Added: 0000023
2004-06-14 19:06 Rogacz Note Added: 0000025
2004-06-14 19:06 Rogacz File Added: debug2.zip
2004-06-14 19:57 almico Note Added: 0000026
2004-06-14 20:04 Rogacz Note Added: 0000027
2004-06-14 20:06 Rogacz Note Added: 0000028
2004-06-14 20:14 almico Note Added: 0000029
2004-06-14 21:00 Rogacz Note Added: 0000030
2004-06-14 21:06 almico Note Added: 0000031
2004-06-14 22:02 almico Note Added: 0000032
2004-06-17 10:47 alfredo Status acknowledged => closed
2004-06-17 10:47 alfredo Note Added: 0000043
2018-08-14 04:38 fusiondog8 Motherboard Model => msi x370 gaming pro carbon