View Issue Details

IDProjectCategoryView StatusLast Update
0002644SpeedFanHardware supportpublic2018-12-10 09:25
ReporterspeedyfannyAssigned Toalfredo 
PrioritynormalSeverityminorReproducibilityalways
Status assignedResolutionopen 
PlatformASUS MAXIMUS VIII GeneOSWin 7 x64OS Versionsp1
Product Version4.52 
Target VersionFixed in Version 
Summary0002644: Samsung 950 Pro temp sensor disappeared after Windows repair install, HWMonitor still sees it
DescriptionWeird problem -

My NVMe temp sensor worked fine in SpeedFan when I first installed the drive. I recently did an in-place "upgrade" to Windows 7 (from Windows 7) to repair some other problem, unrelated to SF.

Since then, the NVMe temp sensor is missing from SF. HWMonitor still sees it fine.

After the repair, I had to install all Windows updates, the Intel RST driver and the Samsung NVMe driver. As far as I know this is the same config I had prior to repair.

I tried re-installing SF after, no change.

Steps To ReproduceStart speedfan
Additional InformationWin9x:NO 64Bit:YES GiveIO:NO SpeedFan:YES
Scanning ISA BUS at $0290...
SuperIO Chip=Nuvoton NCT6793D
WARNING: bad Winbond($5CA3,$C1) identify (NCT6793D,W83677HG-I)
NCT6793D (ID=$C1) found (using SuperIO) on ISA at $290
Nuvoton NCT6793D at $290 msg : Nuvoton NCT6793D uses base address $0A00 too
Nuvoton NCT6793D at $290 msg : Nuvoton NCT6793D uses base address $0A00 too
Scanning Intel SMBus at $F000...
Found Crucial_CT2050MX300SSD1 on AdvSMART
Found Crucial_CT960M500SSD1 on AdvSMART
INFO : SCSI DISABLED by user or because iaStorA.sys is installed
Found System manufacturer System Product Name
Found Radeon (TM) RX 480 Graphics
Found Intel(R) Core(TM) i7-6700K CPU @ 4.00GHz
Loaded 0 events
TagsNo tags attached.
Motherboard ModelASUS Maximus VIII GENE
Video Card ModelRADEON RX480

Activities

speedyfanny

2017-05-16 18:01

reporter   ~0008486

fixed it! I compared a speedfansens.cfg from before the repair to the current one and saw that the sensor was on the SCSI bus, which is not probed when iaStorA.sys is installed.

Samsung Magician complained about "system incompatibility" before the RST driver installed, but after installation I was able to remove it (following the instructions from here: https://answers.microsoft.com/en-us/windows/wiki/windows_7-hardware/uninstalling-the-intelr-rapid-storage-technology/e3c4b6d6-56ba-4ac5-be50-89843c9d9b22 ), Magician is still happy and I can see the sensor in SpeedFan again.

Issue History

Date Modified Username Field Change
2017-05-16 17:20 speedyfanny New Issue
2017-05-16 17:20 speedyfanny Status new => assigned
2017-05-16 17:20 speedyfanny Assigned To => alfredo
2017-05-16 18:01 speedyfanny Note Added: 0008486