View Issue Details

IDProjectCategoryView StatusLast Update
0002614SpeedFanHardware supportpublic2016-12-21 20:01
Reporter09876ggddzzAssigned Toalfredo 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
PlatformX64OSWindows 7 64BitOS VersionSP1
Product Version4.44 
Target VersionFixed in Version4.46 beta 
Summary0002614: DELL-Support not working on 4.44 final (Vostro 3700). 4.44 Beta 6 and 8 work great.
DescriptionFirst of all, I have to tell you a piece of my story.

The DELL Vostro 3700 with Core i5 and NVidia graphics seems to have a problem with temperature control. While the desktop is in idle mode (no process ist running over 4%), the Vostro-fan starts blowing up from 0 to >4000 rpm every 3 seconds. You can read about this problem on DELL-Forums.

Some time ago, a user in the DELL-Forum reportet about the "new" DELL-Support in 4.44 beta, so I gave it a try (with older versions, I had no chance to control the fan). And, it worked! It is not the best solution, because the fan now runs at 2920rpm after the start of speedfan, but it is a lot better then before with blowing from 0 to >4000 every 3 seconds.
Even a DELL-Forum moderator classed the beta 4.44 as solution!!!! (Otherwise, only a mainboard-change can help... because of an faulty temperature sensor or something like this)

With beta 6 and 8, I had no problems to get the DELL-Support working. After activating, the fan runs with 2920rpm.

The final 4.44 did not to work here, with the same options selected as in the beta version.
Additional InformationI attached the debug nfo
TagsNo tags attached.
Motherboard ModelMotherboard ID 63-0100-000001-00101111-010910-Chipset$0AAAA000_BIOS DATE: 01/09/10 15:17:22 VER: 08.00.10
Video Card ModelNVIDIA GeForce GT 330M

Relationships

has duplicate 0001844 closedalfredo Dell support doesn't work with 4.44. Worked well with all 4.44 beta's. 

Activities

2011-07-19 00:29

 

debug.nfo (151,959 bytes)

alfredo

2011-07-23 11:21

manager   ~0008374

Please, contact me by email. I have a beta for you to try.

Udillak

2011-08-06 22:02

reporter   ~0008375

I want to confirm this issue with the final 4.44 version of SpeedFan on my Dell Vostro 3500. All the environment are the same as reporter's except of my notebook does not have nVidia videocard.
I will gladly help in resolving this issue.

Toffer

2011-08-07 07:39

reporter   ~0008376

Hi alfredo,

sorry for the late answer to your mail.

The version of speedfan you sent me via mail did not work either. I will send you a dump later. It is the same issue as with version 4.44 final. The fan does not seem to be controllable.

Livin

2011-08-22 23:48

reporter   ~0008377

Last edited: 2011-08-22 23:50

Same issue with 4.44 final, does not show any fans. Beta 8 shows all 3 fans. Dell Optiplex XE (Core2Duo Intel Q45 chipset : desktop system, not notebook). My video card is ATI/AMD 6450, no NVidia components in the system. Win7 x64 installed

alfredo

2011-08-24 16:23

manager   ~0008378

@Livin
Please contact me at alfredo [at] almico.com

zrajnai

2011-08-25 12:04

reporter   ~0008379

I confirm, that 4.44 final is not working on my Dell Latitude E6410 with Win7 32bit.
Changing the fan speed manually (disabling "Automatic Fan Speed") only has an effect for a fraction of a second. I guess the BIOS is setting the speed back.

I set the speed to 0% and it slows down to 0 RPM for a short time, then it jumps up to around 3200 RPM. Changing the speed between 0% and 5% manually for an extended time seems to keep the RPM down...

zrajnai

2011-08-25 12:17

reporter   ~0008380

I tried previous Betas:
Beta 4, 6, 8 did not recognize my DELL Fan.
Beta 10 exhibits the same behaviour as the final.
I have "Enable DELL support" checked in all cases.
Unfortunately I can't set PWM MODE to MANUALLY CONTROLLED, since PWM MODE does not appear in the list of properties.

Frank

2011-10-08 23:35

reporter   ~0008381

I have the same problem; an old 4.44 beta (don't know exactly which beta) worked perfectly on my vostro 3500 (after enablin dell-support); after updating to 4.44 final it doesn't work. Neither the new 4.45 betas are working.

I would be so happy if somebody could send me one of the old working betas since I deleted the exe, or even better if the next beta works again. ;-)

(The vostro 3500 has an annoying fan!)

Thanks in adavance,
Frank

alfredo

2011-10-09 09:46

manager   ~0008382

Hello Frank, I would like to know exactly what "does not work" means here. On this bug tracker there is another thread where the issue is that the computer hangs for a little every few seconds. This doesn't seem to be the case here.
Am I right if I say that the issue reported here is that the changes that SpeedFan applies to any fan speed are overriden by something else?

Unfortunately, I cannot revert to that specific beta. What's funny is that the beta you are referring to contained a bug in the source code. That bug, basically, was causing some internal SpeedFan storage to become corrupted. It would be funny if I discover that the resulting memory corruption accidentally found the right SMI command and data to be executed :-)

Frank

2011-10-09 19:46

reporter   ~0008383

Last edited: 2011-10-09 20:46

Hello Alfredo,
wow, super-quick response from you; chapeau!

After starting speedfan (with admin-rights!, without it doesn't find any fans) on win7-32bit and enabled DELL-support the program displays all the temperatures and one fan. I can assign the fan to the temperature I want.
After some seconds it starts to decrease the speed, evertyhing looks fine _but_ the fan still runs with full speed. With the working betas the fan-speed decreased when speedfan showed 40% or less speed-fan.
I didn't find any configuration to decrease speed-fan.
Otherwise I have no problems with the program, e.g. computer-hang.

Any help would be great!
Frank

alfredo

2011-10-09 23:27

manager   ~0008384

Frank, please, do a SEND REPORT from SpeedFan, including a reference to this issue in the notes.

Frank

2011-10-10 10:40

reporter   ~0008385

Hello Alfredo,
I've sent a report.
Thanks for your help,
Frank

alfredo

2011-10-10 11:16

manager   ~0008386

I just looked at your report. Everything looks fine. The first question is: what if you manually set SPEED to 0% and then to 100%? Does the fan speed change?

Frank

2011-10-10 13:20

reporter   ~0008387

Hello Alfredo,
if I manually change SPEED between 0% and 100% the speed-fan is unchanged; unfortunately the same beahaviour than "automatic fan speed".

Best regards
Frank

alfredo

2011-10-15 09:57

manager   ~0008388

Very interesting news. I have a new beta that WORKS on a VOSTRO. Now the question is: will it work on EVERY VOSTRO? :-)
Contact me by email and I will send you the beta.

Livin

2011-10-15 18:06

reporter   ~0008389

I've been using 4.45 beta 3.24 on my Optiplex and it has been working.

Frank

2011-10-17 15:57

reporter   ~0008390

Dear Alfredo
unfortunately the 4.45 beta 5.19 is not working my Vostro 3500 :-(

Although Speedfan shows reducing the percentage of speed of the fan, but in reality it has no effect: the fan-speed is still high.
The same happens if I reduce the SPEED down to 0%, it has no effect of the real fan-speed.

Nevertheless thanks a lot for your help!

Best regards,
Frank

Roger

2011-10-24 12:49

reporter   ~0008391

Just to confirm Frank's findings completely.

Vostro 3500 with Win7 32Bit Professional

alfredo

2011-10-24 13:00

manager   ~0008392

@Roger
Which beta did you test?

Roger

2011-10-24 14:07

reporter   ~0008393

4.44 beta 4 worked like a charm.

After the expiry, no version worked at all, exactly as Frank described.

Udillak

2011-11-04 08:37

reporter   ~0008394

4.45 final has no effect on a CPU fan on Dell Vostro 3500.
If I manually set 0% for a fan it still continue to spin at 4000RPM. This was not a case for 4.44 early betas. One thing more, I cannot see any specific DELL commands inside commands log window which supposed to indicate program's tries to regulate rotations of a fan. In early betas of 4.44 there were such commands on every speed change or so.

alfredo

2011-11-04 08:56

manager   ~0008395

I have a private SpeedFan 4.46 beta that might improve things. Please, contact me by mail.

Frank

2011-11-05 23:04

reporter   ~0008396

Dear Alfredo,
just to confirm Udillak, that 4.45 final still doesn't work on Vostro 3500.

Nevertheless i appreciate your efforts.
Maybe you can send me the 4.46beta, too?

Best regards,
Frank

alfredo

2011-11-06 10:38

manager   ~0008397

Hello Frank, please, contact me by email.

Frank

2011-11-09 10:03

reporter   ~0008398

Last edited: 2011-11-09 15:12

Dear Alfredo,
thanks for the 4.46beta 1.5.8:
As far as i can see it works on my VOSTRO3500! ;-)

I will test it further and keep you informed!
Thanks a lot!

Best regards,
Frank

Udillak

2011-11-09 10:59

reporter   ~0008399

I am also want to confirm that Vostro 3500 indeed gets fan controlled by SpeedFan 4.46beta.

Anst

2011-11-15 04:35

reporter   ~0008400

Hi Alfredo,
Can you send me the 4.46beta too?
I wanna test it on my laptop (Dell Vostro 3700 win7-32bit)
Thanks.

Frank

2011-11-26 20:40

reporter   ~0008401

Dear Alfredo,
after 2 weeks of testing I am absolutely satisfied!
It works very well.

Thanks for your help!

Frank

alfredo

2011-12-03 17:38

manager   ~0008402

SpeedFan 4.46 beta 2 is online and includes the latest fixes for DELLs.

Frank

2011-12-09 22:32

reporter   ~0008403

Dear Alfredo,
SpeedFan 4.46 beta 2 works, too.
Best regards
Frank

Issue History

Date Modified Username Field Change
2016-12-21 20:01 09876ggddzz New Issue
2016-12-21 20:01 09876ggddzz Issue generated from: 0001843