View Issue Details

IDProjectCategoryView StatusLast Update
0002417SpeedFanHardware supportpublic2019-03-25 16:23
ReportertovtAssigned Toalfredo 
PriorityhighSeveritymajorReproducibilityalways
Status assignedResolutionopen 
PlatformWindows x64OSW7x64 SP1, XP Pro x64 (Srv 2003)OS VersionWin 7 (6.1.7601)
Product Version4.50 
Target VersionFixed in Version 
Summary0002417: Turns into _non-responsive state_ (Timeout waiting IDLE SMBus $14 ..) within 10min-2hours
DescriptionHW: SuperMicro X7DCL MB (Intel 5100 chipset)
 (details are in .nfo-s)

OS: Current logs are form W7x64, but behavior for XPx64 (Srv2003) SP2 is the same.

 ---== [ Problem description ] ==---
Briefly:
SpeedFan v.4.51 can start normally. But after 0000006:0000010 min - 1 hour, it hangs (while freezing all the fan controls and showing no fan speeds and no temps sometimes). The 'Readings'-tab main message window shows:
| Scanning Intel SMBus at $1100...
| SMBus msg : Timeout waiting IDLE SMBus $14 (STS=$41)

-> In case of successful start, it reports here after the 1st line above:
| Winbond W83627HF (ID=$21) found on SMBus at $2D
| Winbond W83793G (ID=$7B) found on SMBus at $2F
| LM75 found on SMBus at $48
| LM75 found on SMBus at $49

--> after sometime, connection (presumably, to some Winbond chips over SMBus) breaks permanently (MB power off can only help!), it reports:
| SMBus msg : Timeout waiting IDLE SMBus $14 (STS=$41)
| ..
| SMBus msg : Timeout waiting IDLE SMBus $77 (STS=$41)

(after that it might stop and return back into responsive state: See '2015-08-11_(1)--StartedFineButLostWinbondConnWithTime'- folder in the logs package)

--------------
(but sometimes it cannot return from non-responsive state at all)

---> So, in this case .nfo cannot be extracted (after forceful shutdown it is not saved as well) and on the main 'Readings'-tab window it cycles through the following messages eternally. Cannot be copy-pasted, so just retyped from what was visible on the screen:
| SMBus msg: Timeout waiting IDLE SMBus $2D (STS=$4..)
| ..
| SMBus msg: <TimeStamp> Unsuccessful WRITEB $4E ...
| ..


Both SF restart and SF restart after PC reboot cannot help in restoring connection to the Winbond (W83627HF/W83793G) chip(s), so the PC has to be powered off for sometime before trying again with a chance for normal start.

The folder names contain the state description in brief and date/try in chronological order.

(Note, .nfo-s contain complains about MB support: "Error 3 while extracting CFG (Supermicro X7DCL Supermicro X7DCL) from ZIP". Is the HW config read/supported fine by SF?)
Steps To Reproduce1) Install SpeedFan v.4.51 (Win7 x64 SP1 or Win XP Pro x64 (Srv2003 kernel) SP2 with all recent updates)
2) Run SpeedFan v.4.51
3) If responsive, leave it working until it gets non-responsive while stopping controlling and showing the fan speeds (and sometimes some temp-s).
Additional InformationHW (Supermicro MB) might have relevance to the issue 0001799 filed before:
 (http://www.bugtrack.almico.com/view.php?id=1799)

SMBus message ('SMBus msg : Timeout waiting IDLE SMBus $40 (STS=$__)') can have relevance to the issue 0000581 reported before:
 (http://www.bugtrack.almico.com/view.php?id=581)
TagsNo tags attached.
Motherboard ModelSuperMicro X7DCL
Video Card Model

Activities

tovt

2015-08-12 17:11

reporter  

SpFn_4.51_FAILURES_W7x64_.zip (95,608 bytes)

Issue History

Date Modified Username Field Change
2015-08-12 17:11 tovt New Issue
2015-08-12 17:11 tovt Status new => assigned
2015-08-12 17:11 tovt Assigned To => alfredo
2015-08-12 17:11 tovt File Added: SpFn_4.51_FAILURES_W7x64_.zip