View Issue Details

IDProjectCategoryView StatusLast Update
0002287SpeedFanLogging and chartingpublic2014-08-19 09:36
ReporterzAlbeeAssigned Toalfredo 
PrioritynormalSeverityminorReproducibilityalways
Status acknowledgedResolutionopen 
PlatformIntel Core 2 DuoOSWindowsOS Version7 (64-bit)
Product Version4.49 
Target VersionFixed in Version 
Summary0002287: Chart doesn't scale time axis properly
DescriptionLove the program and I use it all on my machines to monitor temperatures. But the charts stopped scaling properly in the latest version.

On my laptop, there are 5 temperatures that I can chart: GPU, HD0, Temp1, Core 0, Core 1. For most of them, the chart shows the past 13 minutes only. But for HD0, the chart shows all data since I last rebooted. So once I enable "HD0" chart, then the time scale for all charts is changed and the graph becomes compressed. All charts except "HD0" show a flat horizontal line.

See screenshot. Notice the "Start time" is more than 24 hours before the "End time".
Steps To ReproduceHave Speedfan running for 15 minutes or more. Under temperature charts, check the box next to "HD0".
Additional InformationThis didn't happen with older Speedfan versions. I'm not sure which version started the problem.

This is a 2009 laptop (Dell XPS 1340)

Win9x:NO 64Bit:YES GiveIO:NO SpeedFan:YES
I/O properly initialized
Linked ISA BUS at $0290
Linked nVidia MCP79 SMBUS at $3040
Linked nVidia MCP79 SMBUS at $2000
Found nVidia GeForce 9400M G
Linked nVidiaI2C0 SMBUS at $3D403E3F
Linked nVidiaI2C1 SMBUS at $3D403637
Linked nVidiaI2C2 SMBUS at $3D405051
Scanning ISA BUS at $0290...
SuperIO Chip=IT8512E
Scanning nForce2 SMBus at $3040...
Scanning nForce2 SMBus at $2000...
Scanning I2CNVidia SMBus at $3D403E3F...
Scanning I2CNVidia SMBus at $3D403637...
Scanning I2CNVidia SMBus at $3D405051...
Found ST9320423ASG on AdvSMART
Found ACPI temperature
Found Intel(R) Core(TM)2 Duo CPU P8600 @ 2.40GHz
End of detection
TagsNo tags attached.
Motherboard ModelDell 0K183D - nForce 730i chipset (reported by CPU-Z)
Video Card Model

Activities

zAlbee

2014-08-17 21:28

reporter  

speedfan449-chart-bad.png (12,349 bytes)
speedfan449-chart-bad.png (12,349 bytes)

zAlbee

2014-08-17 21:31

reporter  

speedfan449-chartok.png (14,961 bytes)
speedfan449-chartok.png (14,961 bytes)

zAlbee

2014-08-17 21:32

reporter   ~0007499

I attached a second screenshot that shows the chart looking as expected when I uncheck "HD0".

alfredo

2014-08-19 09:36

manager   ~0007505

You are right. The idea is that SpeedFan shows all the available samples for the specific reading and, since HDs sample less frequently, this causes what you see. I need to rework the charting tab.

Issue History

Date Modified Username Field Change
2014-08-17 21:28 zAlbee New Issue
2014-08-17 21:28 zAlbee Status new => assigned
2014-08-17 21:28 zAlbee Assigned To => alfredo
2014-08-17 21:28 zAlbee File Added: speedfan449-chart-bad.png
2014-08-17 21:31 zAlbee File Added: speedfan449-chartok.png
2014-08-17 21:32 zAlbee Note Added: 0007499
2014-08-19 09:36 alfredo Note Added: 0007505
2014-08-19 09:36 alfredo Status assigned => acknowledged