View Issue Details

IDProjectCategoryView StatusLast Update
0002215SpeedFanHardware supportpublic2014-08-19 13:34
Reporterdoum-ti-di-li-doomAssigned Toalfredo 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionopen 
PlatformPCOSWindowsOS Version8.1
Product Version4.49 
Target VersionFixed in Version4.50 
Summary0002215: Drives are wrong when plugging USB drive
DescriptionI have a 120GB drive in my computer.
When I plug my 500GB USB drive and start SpeedFan, the 120 goes missing, the 500 uses the other's name and its SMART data is mixed up
TagsNo tags attached.
Motherboard ModelASUS P8B75M/CSM
Video Card Model

Activities

doum-ti-di-li-doom

2014-01-25 20:17

reporter  

configure comparison.png (34,404 bytes)
configure comparison.png (34,404 bytes)

doum-ti-di-li-doom

2014-01-25 20:19

reporter  

smart wrong.png (59,472 bytes)
smart wrong.png (59,472 bytes)

doum-ti-di-li-doom

2014-01-25 20:28

reporter   ~0007322

Startup log is identical in both cases
*SCSI disabled because of Intel RST crash/bug...


Win9x:NO 64Bit:YES GiveIO:NO SpeedFan:YES
I/O properly initialized
Linked ISA BUS at $0290
Linked Intel 7 Series SMBUS at $F000
Scanning ISA BUS at $0290...
SuperIO Chip=Nuvoton NCT6779D
NCT6779D (ID=$C1) found (using SuperIO) on ISA at $290
Scanning Intel SMBus at $F000...
Found KINGSTON SV300S37A120G on AdvSMART
INFO : SCSI DISABLED by user
Found ACPI temperature
Found AMD Radeon HD 7800 Series
Found Intel(R) Core(TM) i3-3240 CPU @ 3.40GHz
End of detection
Loaded 0 events

doum-ti-di-li-doom

2014-08-08 04:07

reporter   ~0007419

SpeedFan 4.50 beta 2 : looking good

There is probably another bug to mark this one duplicate of

alfredo

2014-08-08 20:04

manager   ~0007422

While I agree that SpeedFan might assign a short name to drives that is somewhat perfectible ;-), the drive model, firmware, serial and SMART data is always correct. If this is not your case, then there must be some kind of bug in the driver.
The problem is that the same hard disk might be reachable using multiple methods. The latest beta has slightly changed the order used to test each method. There was a rare case where one method "seemed" to be working, thus blocking the next one to be picked up.
If I understood your last message, the latest beta fixes this issue. Is this correct?

Issue History

Date Modified Username Field Change
2014-01-25 20:17 doum-ti-di-li-doom New Issue
2014-01-25 20:17 doum-ti-di-li-doom Status new => assigned
2014-01-25 20:17 doum-ti-di-li-doom Assigned To => alfredo
2014-01-25 20:17 doum-ti-di-li-doom File Added: configure comparison.png
2014-01-25 20:19 doum-ti-di-li-doom File Added: smart wrong.png
2014-01-25 20:28 doum-ti-di-li-doom Note Added: 0007322
2014-08-08 04:07 doum-ti-di-li-doom Note Added: 0007419
2014-08-08 20:04 alfredo Note Added: 0007422
2014-08-08 20:04 alfredo Status assigned => acknowledged
2014-08-19 13:34 alfredo Status acknowledged => resolved
2014-08-19 13:34 alfredo Fixed in Version => 4.50
2016-12-21 20:01 09876ggddzz Issue cloned: 0002594