View Issue Details

IDProjectCategoryView StatusLast Update
0002105SpeedFanHardware supportpublic2013-03-30 17:58
ReporterBzzzAssigned Toalfredo 
PrioritynormalSeverityblockReproducibilityalways
Status assignedResolutionopen 
PlatformWindowsOS7OS Versionx64
Product Version4.47 
Target VersionFixed in Version 
Summary0002105: Hangs when hard disks are attached to IBM BR10i SAS controller
DescriptionHi,

Speedfan 4.48 and 4.48 Beta 6 (both cannot be chosen atm in the dropdown field) hang when HDDs are attached to my SAS controller. It works well if there is no HDD present. It also works if started in SMBDEBUG mode, however it only recognizes three temp sensors and nothing else. NOSMB crashes as well.
SF hangs and has to be closed forcefully. After that, HDD access is no longer possible for other applications. As I was running a SMART self-test for the very first time I tried, this test was also stopped forcefully (gsmartcontrol says because of host reset). Windows doesn't shut down properly afterwards, so I call that a blocker.
Steps To ReproduceBuy BR10i and flash to IT mode (HBA only, no RAID functionality) ;)
Attach at least one HDD
Boot
Start Speedfan
Hangs at "Scanning ISA BUS at $0CCB..."
Additional InformationThe IBM BR10i is based on a LSI card, just rebranded and stripped of some advanced RAID functionality. It is flashed with IT firmware, meaning it only acts as a Host Bus Adapter, doing no RAID stuff at all. Just handling over every single driver as it is.
I use SATA drives with it over an SFF-8087 to 4x SATA breakout cable, and the drives have had 40 hours of testing without errors prior to installation and first start of Speedfan.
BR10i sits in the PCIe x16 slot (full x16), as the board doesn't offer a real x8. The graphics card occupies the x16@x4 slot (but I use RDP, so that doesn't make a difference)
TagsNo tags attached.
Motherboard ModelAsus M5A97 LE R2.0
Video Card ModelRadeon HD 3450

Activities

Bzzz

2013-03-10 16:54

reporter  

speedfan_debug.nfo (145,825 bytes)

Bzzz

2013-03-30 17:58

reporter   ~0007197

Unfortunately still present in 4.49.

Issue History

Date Modified Username Field Change
2013-03-10 16:54 Bzzz New Issue
2013-03-10 16:54 Bzzz Status new => assigned
2013-03-10 16:54 Bzzz Assigned To => alfredo
2013-03-10 16:54 Bzzz File Added: speedfan_debug.nfo
2013-03-30 17:58 Bzzz Note Added: 0007197