View Issue Details

IDProjectCategoryView StatusLast Update
0001797SpeedFanOtherpublic2011-05-09 03:28
Reporterwlw_wlAssigned Toalfredo 
PrioritynormalSeveritycrashReproducibilityrandom
Status acknowledgedResolutionopen 
PlatformAMD (ASRock 870 Extreme3)OSWin 7 Pro x64OS VersionSP1 or not
Product Version4.43 
Target VersionFixed in Version 
Summary0001797: Speedfan crashes or locks up the computer
DescriptionHi Alfredo,

I have serious stability issues that carried on to a fresh installation of OS.
I have ruled out hardware issues with many extensive tests, such as (but not limited to) MHDD and MemTest.

It concerns both 4.43 and 4.44 up to newest beta.

Whenever SpeedFan is running in the background, the computer will randomly crash, restart, BSOD (124, 7E, 1E among others) or freeze. Most times after freeze and hard reset the system will BSOD with 0x7E - CI.dll on boot which suggests system files corruption (SpeedFan driver?). It goes away after another reset.

It happens randomly during normal usage such as browsing the Internet as well as during gaming.
It often happens when Windows launches and SpeedFan is started with Sheduler entry. The desktop just freezes.

It seems to be more likely to happen when I have Sapphire Trixx (3.0.5, 3.0.6 and newest 3.0.7 {mislabeled as 4.0 on their website}) for the GPU running as well.
However the Trixx alone doesn't produce such issues and SpeedFan does

I thought it might be related to automatic fan speed variation, but unfortunately it isn't. Setting the speeds manually and unticking the checkbox doesn't improve the situation.

The problem occur exclusively when SpeedFan is running, either as only a monitoring app or adjusting the fans. BSODs such as PAGE_FAULT, IRQL_NOT_LESS and MEMORY_MANAGEMENT occur, which leads me to conclusion that the SpeedFan's driver might be causing some conflicts with other hardware.
I can run OCCT (even on overclocked system) for an hour with no problems, but add SpeedFan to that (no OC) and it won't last more than couple of minutes.

As this started happening out of the blue on another fresh system installation, it seems to be unrelated to either Windows Updates or any other particular application.

I am attaching a photo of how the freeze case looks like, accompanied by looping sound and sometimes hard reboot.

Ask for any details you might need, I'm sure I missed something.
TagsNo tags attached.
Motherboard ModelASRock 870 Extreme3
Video Card ModelSapphire HD6850

Activities

wlw_wl

2011-04-26 20:33

reporter  

Zdjecie0085.jpg (348,705 bytes)

wlw_wl

2011-04-26 20:42

reporter   ~0006134

I'll try to collect and attach the debug.nfo, I forgot about that one.

wlw_wl

2011-04-27 00:28

reporter   ~0006135

Further analysis leads me to conclusion that the SpeedFan is conflicting with AMD North Bridge filter driver.

alfredo

2011-04-28 11:41

manager   ~0006142

Did you have a chance to try an older SpeedFan release?

wlw_wl

2011-04-28 15:40

reporter   ~0006144

How much older would that be?

alfredo

2011-04-28 15:53

manager   ~0006145

Even 4.42 might do.

wlw_wl

2011-05-09 03:28

reporter   ~0006178

I have a question.

Does SpeedFan use HPET, especially when doing fan auto-control?

Issue History

Date Modified Username Field Change
2011-04-26 20:33 wlw_wl New Issue
2011-04-26 20:33 wlw_wl Status new => assigned
2011-04-26 20:33 wlw_wl Assigned To => alfredo
2011-04-26 20:33 wlw_wl File Added: Zdjecie0085.jpg
2011-04-26 20:42 wlw_wl Note Added: 0006134
2011-04-27 00:28 wlw_wl Note Added: 0006135
2011-04-28 11:41 alfredo Note Added: 0006142
2011-04-28 11:41 alfredo Status assigned => acknowledged
2011-04-28 15:40 wlw_wl Note Added: 0006144
2011-04-28 15:53 alfredo Note Added: 0006145
2011-05-09 03:28 wlw_wl Note Added: 0006178