View Issue Details

IDProjectCategoryView StatusLast Update
0000014SpeedFanHardware supportpublic2018-08-14 04:40
Reporterm3tw0Assigned Toalfredo 
PrioritynormalSeveritymajorReproducibilityalways
Status closedResolutionopen 
PlatformIntel Pentium 3.0COSWindows XP ProOS VersionNT5
Product Version4.12 
Target VersionFixed in Version 
Summary0000014: Nvidia visual problems in 3D games and or benchmarks when using SpeedFan
Descriptionusing any driver from the 5X.XX series of drivers from Nvidia with an MSI GeForce 4 TI4200 8x Graphics card along with SpeedFan will interfere with the normal operation of the graphics card. The Fan and temperature for the Graphics card are displayed and the speed can be controlled, but when running both DirectX and or OpenGL 3D benchmarks or applications severe graphic flickering and flashing as well as pallate changes ie. negative colors, will result. SpeedFan will report Errors on the Nvidia Bus and shows as NOT RESPONDING eventually hanging.
Steps To ReproduceInstallation of any driver above 5X.XX both from Nvidia or the graphics card manufacturer, together with SpeedFan running
Additional Informationmay have other side effects with another GeForce 4 TI4600 from Leadtek such as extended pausing -- will need to do more testing to confirm this.
TagsNo tags attached.
Motherboard Modelmsi x370 gaming pro carbon
Video Card ModelMSI Geforce 4 TI4200 8x

Activities

alfredo

2004-06-21 00:44

manager   ~0000054

I will add some quick menu option to temporarily disable Graphic Card's access upon user request to avoid such interference.

m3tw0

2004-06-21 04:24

reporter   ~0000055

Last edited: 2004-06-21 04:25

that is good news, the "option" would need to be something that once set, when the program starts, it remembers the setting, because once SpeedFan accesses the Nvidia Bus the problem seems to happen even when the program is shutdown. Thanks for the quick response, and a great program.

edited on: 06-21-04 04:25

alfredo

2004-06-21 10:47

manager   ~0000056

I'm trying to figure out the best way to implement this "option". Currently I'm considering an option that can be easily set by accessing the tray icon. This option would disable polling temps and the likes from the video card. The end user should activate this option prior to using a DirectX or OpenGL app.
I will search for a way to autodetect such apps starting to try to act automatically, but, in the meantime...
You can always disable video card support by using the following command line option:

/NONVIDIAI2C

m3tw0

2004-06-21 17:46

reporter   ~0000058

the command line solution /NONVIDIAI2C
works perfectly I now have speed fan and working video drivers as well
THANK YOU

An automatic disable when an application starts to use directX or opengl sounds very interesting and would be nice to have since the fan speed and temperature for the NVIDIA bus was a bonus, but with this command line fix it works.

m3tw0

2004-06-24 09:06

reporter   ~0000066

Just to confirm - in my additional notes I mentioned that a possible problem also was occuring with a GeForce 4 TI 4600 - this problem was something other than SpeedFan, the card turned out not to be able to be monitored, and no problems resulted from the use of speedfan.

alfredo

2004-07-14 20:29

manager   ~0000155

The /NONVIDIAI2C command line option fixes this issue.
I'm closing this bug, but I will add some more elegant fix in the (near) future :-)

Issue History

Date Modified Username Field Change
2004-06-20 21:10 m3tw0 New Issue
2004-06-20 21:10 m3tw0 Video Card Model => MSI Geforce 4 TI4200 8x
2004-06-21 00:44 alfredo Note Added: 0000054
2004-06-21 00:44 alfredo Status assigned => acknowledged
2004-06-21 00:44 alfredo Projection none => tweak
2004-06-21 00:44 alfredo ETA none => < 1 month
2004-06-21 04:24 m3tw0 Note Added: 0000055
2004-06-21 04:25 m3tw0 Note Edited: 0000055
2004-06-21 10:47 alfredo Note Added: 0000056
2004-06-21 17:46 m3tw0 Note Added: 0000058
2004-06-24 09:06 m3tw0 Note Added: 0000066
2004-07-14 20:29 alfredo Note Added: 0000155
2004-07-14 20:29 alfredo Status acknowledged => closed
2004-07-14 20:29 alfredo Projection tweak => none
2004-07-14 20:29 alfredo ETA < 1 month => none
2018-08-14 04:38 fusiondog8 Motherboard Model => msi x370 gaming pro carbon