View Issue Details

IDProjectCategoryView StatusLast Update
0002259SpeedFanHardware supportpublic2019-03-29 07:38
ReporteripsanzAssigned Toalfredo 
PrioritynormalSeveritycrashReproducibilityalways
Status acknowledgedResolutionopen 
PlatformPCOSWindowsOS Version8.1 x64 Update 1
Product Version4.49 
Target VersionFixed in Version 
Summary0002259: SpeedFan freezes computer when started and any USB drives are plugged
DescriptionThe computer completely freezes when SpeedFan is started if you have any USB drive plugged into the motherboard. Hard reset must be used in order to restart Windows.
Steps To ReproduceAttach any USB drive (tried pendrive / harddisk) to any of the motherboard USB connectors, and start SpeedFan. It doesn't matter if it's a USB 2.0 or 3.0 device and wheteher you use USB 2.0 or 3.0 ports. The result is always the same.

I disabled SMBus sensors scanning because ISA BUS is all what I need, but the problem still happens.
Additional InformationThis is the log from SpeedFan initialization window. Note the WARNING:

Win9x:NO 64Bit:YES GiveIO:NO SpeedFan:YES
I/O properly initialized
Linked ISA BUS at $0290
Scanning ISA BUS at $0290...
SuperIO Chip=Nuvoton NCT6776F
WARNING: bad Winbond($5CA3,$C1) identify (NCT6776F,W83677HG-I)
NCT6776F (ID=$C1) found (using SuperIO) on ISA at $290
Found SAMSUNG HM160HI on AdvSMART
Found SanDisk SDSSDP064G on AdvSMART
Found ACPI temperature
Found Intel(R) Celeron(R) CPU J1900 @ 1.99GHz
End of detection
Loaded 0 events

Once freezed, unplugging the USB drive doesn't unfreeze the system. If you start SpeedFan without USB drives plugged, it all works as expected.
TagsNo tags attached.
Motherboard ModelASRock Q1900-ITX
Video Card ModelIntel HD Graphics

Activities

Cozman

2014-08-22 20:53

reporter   ~0007555

Win 8.1 x64
I had the same problem with both 4.49 & 4.50.
Bluescreen appeared after a very short program window that showed a tiny bit of info.
Bluescreen showed message DRIVER_IRQL_NOT_LESS_OR_EQUAL (iaStorA.sys)

I then installed Intel RST 13.1 (4.50 is installed).
It still would not run. Error message <SPEEDFAN driver not installed>
I then uninstalled SpeedFan then reinstalled.
It now works.

It seems that there should be a warning on the main page or download page
stating that there are big problems with Win 8.1.
I bet a lot of people tried it on w8.1 with an older version of Intel RST
installed and gave up after it would not work.
People that will never come back or donate.

alfredo

2014-08-23 01:41

manager   ~0007557

@ipsanz: I will be glad to help understand why on your system there is this issue. Nobody else ever reported it. If you use "/NOADVSMARTSCAN" the issue will be gone.

@cozman: yours is a different issue and you should blame "iastora.sys" driver. SpeedFan works great under Windows 8.1. There are some buggy drivers (like some versions of iastora.sys) that get hit by legitimate calls issued by SpeedFan. The "SPEEDFAN driver not installed" message most likely happened because you installed SpeedFan, started it and the iastora.sys crash caused the configuration changes not to be saved.

alfredo

2014-08-23 08:36

manager   ~0007559

@cozman: your last sentence, unfortunately, might be true :-(

alfredo

2014-08-23 11:22

manager   ~0007560

Ok. I am working on a beta that automatically applies /NOSCSISCAN if the "iaStorA" driver is installed. The /DOSCSISCAN command forces enable SCSI scan, if needed.

Issue History

Date Modified Username Field Change
2014-06-02 10:16 ipsanz New Issue
2014-06-02 10:16 ipsanz Status new => assigned
2014-06-02 10:16 ipsanz Assigned To => alfredo
2014-08-22 20:53 Cozman Note Added: 0007555
2014-08-23 01:35 alfredo Status assigned => acknowledged
2014-08-23 01:41 alfredo Note Added: 0007557
2014-08-23 08:36 alfredo Note Added: 0007559
2014-08-23 11:22 alfredo Note Added: 0007560