Almico's Bug Tracker - SpeedFan
View Issue Details
0002444SpeedFanHardware supportpublic2015-10-11 11:142019-03-28 11:03
lowsenser 
alfredo 
urgentminorhave not tried
acknowledgedopen 
Intel Z 170Windows10
4.52 beta 
4.52 beta 
Gigabyte Z170x-Gaming 7
0002444: Add support for IT8628E
Hi Alfredo, at first Thank u for Speedfan...

I Have a new Skylake Plattform and after installing Windows and Drivers, the first Programm im every time installing is Speedfan, but it doesnt work with the new Z170 Chipset.

I have sending u an Report from inside of Speedfan, i hope u will add Z170 support soon.

best reggards from germany
IT8628E
related to 0002424resolved alfredo Does speedfan support z170 
related to 0002574resolved alfredo Does speedfan support z170 
Issue History
2015-10-11 11:14lowsenserNew Issue
2015-10-11 11:14lowsenserStatusnew => assigned
2015-10-11 11:14lowsenserAssigned To => alfredo
2015-10-13 21:55ZwoCaNote Added: 0007881
2015-10-30 15:27alfredoStatusassigned => resolved
2015-10-30 15:27alfredoResolutionopen => fixed
2015-10-30 15:27alfredoFixed in Version => 4.52 beta
2015-10-30 15:28alfredoRelationship addedduplicate of 0002424
2015-10-30 17:00lowsenserNote Added: 0007897
2015-10-30 17:00lowsenserStatusresolved => feedback
2015-10-30 17:00lowsenserResolutionfixed => reopened
2015-10-30 17:02lowsenserNote Added: 0007898
2015-10-30 17:02lowsenserStatusfeedback => assigned
2015-10-30 19:31alfredoRelationship replacedrelated to 0002424
2015-10-30 19:34alfredoNote Added: 0007901
2015-10-30 19:34alfredoStatusassigned => acknowledged
2015-10-30 19:34alfredoResolutionreopened => open
2015-10-30 20:40lowsenserNote Added: 0007903
2015-10-30 20:58alfredoNote Added: 0007904
2015-11-01 11:23alfredoSummaryZ170 No Fan Control => Add support for IT8628E
2015-11-01 11:24alfredoNote Added: 0007912
2016-01-10 01:40LaughmoreNote Added: 0007948
2016-01-10 01:41LaughmoreTag Attached: IT8628E
2016-01-10 05:51LaughmoreNote Edited: 0007948bug_revision_view_page.php?bugnote_id=7948#r811
2016-01-14 10:17FurboNote Added: 0007950
2016-11-09 22:44ZwoCaNote Added: 0008053
2016-11-09 22:44ZwoCaNote Edited: 0008053bug_revision_view_page.php?bugnote_id=8053#r878
2016-11-12 10:44nstretchNote Added: 0008054
2016-11-20 22:12GuidoNote Added: 0008056
2017-01-21 18:32Dan-HNote Added: 0008461
2017-01-21 22:17nstretchNote Added: 0008462
2017-01-22 20:26metallsimonNote Added: 0008463
2017-02-09 20:44ketchUPNote Added: 0008466
2017-05-20 15:14snifitNote Added: 0008487
2017-05-20 15:14snifitNote Edited: 0008487bug_revision_view_page.php?bugnote_id=8487#r906
2017-11-12 23:40JannFNote Added: 0008511
2019-01-02 09:24user5462Note Added: 0008743
2019-02-28 17:06user5690Note Added: 0008945
2019-03-28 11:03user5819Note Added: 0009126
2019-04-01 11:41almicoNote Deleted: 0008743
2019-04-01 11:41almicoNote Deleted: 0009126
2019-04-01 11:41almicoNote Deleted: 0008945

Notes
(0007881)
ZwoCa   
2015-10-13 21:55   
Hi guys,
similiar motherboard is in use here (Gigabyte Z170X-UD3).

Seems like the Z170 Gigabyte motherboards are using the IT8628E Super IO chip, they feature 5 PWM controlled fan headers so maybe the chip is similiar to the IT8620E of "older" Gigabyte platforms?
(0007897)
lowsenser   
2015-10-30 17:00   
Hi Alfredo, i Test the Beta 4 and it doesnt work on my system.

I have tested in Bios the Fan Settings : Full, Quiet and Manual !


A Report from the Info Tab was send to you... hopefully it help you to recognize the problem.

best reggards
(0007898)
lowsenser   
2015-10-30 17:02   
My Speedfan Beta 4 startlog:


Win9x:NO 64Bit:YES GiveIO:NO SpeedFan:YES
I/O properly initialized
Linked ISA BUS at $0290
Linked Intel Sunrise Point SMBUS at $F000
Scanning ISA BUS at $0290...
SuperIO Chip=IT8628E
Linked ISA BUS at $0A40
Scanning Intel SMBus at $F000...
Scanning ISA BUS at $0A40...
IT8628E found on ISA at $A40
Found SAMSUNG SSD 830 Series on AdvSMART
Found WDC WD3200AAJS-00VWA0 on AdvSMART
Found Hitachi HDT721010SLA360 on AdvSMART
INFO : SCSI DISABLED by user or because iaStorA.sys is installed
Found ACPI temperature
Found AMD Radeon HD 7900 Series
Found Intel(R) Core(TM) i5-6600K CPU @ 3.50GHz
End of detection
Loaded 0 events
(0007901)
alfredo   
2015-10-30 19:34   
Hi :-)
In your case the issue is not really Z170 support (which works), but IT8628E support. I do not have a datasheet and I hope not to be forced to purchase a motherboard and spend days trying to find required registers ;-)
(0007903)
lowsenser   
2015-10-30 20:40   
hi,
Can i Help u with anything like running some programs etc. ?
(0007904)
alfredo   
2015-10-30 20:58   
Please, contact me by email at alfredo at almico . com
(0007912)
alfredo   
2015-11-01 11:24   
I changed the title of this issue to make it more informative.
(0007948)
Laughmore   
2016-01-10 01:40   
(edited on: 2016-01-10 05:51)
Same issue, Gigabyte GA-Z170MX, no fans detected.

(0007950)
Furbo   
2016-01-14 10:17   
Just letting you know that it's the same with Gigabyte GA-Z170X-Gaming 3-EU motherboard, it uses IT8628E (found on ISA at $A40).
(0008053)
ZwoCa   
2016-11-09 22:44   
Hi Alfredo. While still there is no datasheet available for the IT8628E, it seems like there exists a linux kernel driver supporting it: https://github.com/groeck/it87/issues/5 [^]
Maybe the source provides some useful information to you.

(0008054)
nstretch   
2016-11-12 10:44   
Hi Alfredo,

I also have a Gigabyte Gaming 7 motherboard and would love to be able to control fans with speedfan. Anything I can do to help?
(0008056)
Guido   
2016-11-20 22:12   
Hi Alfredo,
Just to let you know, I have a Gigabyte GA-Z170XP-SLI and i have the same issue.

This is my startlog:

Win9x:NO 64Bit:YES GiveIO:NO SpeedFan:YES
I/O properly initialized
Linked ISA BUS at $0290
Linked Intel Sunrise Point SMBUS at $F000
Scanning ISA BUS at $0290...
SuperIO Chip=IT8628E
Linked ISA BUS at $0A40
Scanning Intel SMBus at $F000...
Scanning ISA BUS at $0A40...
IT8628E found on ISA at $A40
Found Samsung SSD 840 EVO 120GB on AdvSMART
Found CT250BX100SSD1 on AdvSMART
Found WDC WD20EZRZ-00Z5HB0 on AdvSMART
Found ST1000DM003-1CH162 on AdvSMART
INFO : SCSI DISABLED by user or because iaStorA.sys is installed
Found ACPI temperature
Found AMD Radeon (TM) R9 390 Series
Found Intel(R) Core(TM) i5-6600 CPU @ 3.30GHz
End of detection
Loaded 0 events

A report has been sent thorugh speedfan itself as well.
If i can assist you in any way please let me know.
Best regards,

Guido
(0008461)
Dan-H   
2017-01-21 18:32   
Happy new year. Is there an update or timeline for the IT8628E to be supported?
(0008462)
nstretch   
2017-01-21 22:17   
In case this helps someone else, the main reason I wanted to use Speedfan for the Gaming 7 rather than the Gigabyte fan software was that I was experiencing significant speed variability with my push-pull cpu fans. They were all over the place. What I discovered was that if I stopped powering them off a splitter from the CPU header, and moved one to the secondary CPU header, the problem is gone. I had the splitter from my previous board since it only had one header, and never had problems there, but I guess with this board the speed feedback signals from the two fans interfere, or something like that. Using two separate headers (with the same map for each) works well.
(0008463)
metallsimon   
2017-01-22 20:26   
Same for me. Im Using a trial Version of Argus Monitor right now, but i'd like to use Speedfan again. I have GA-Z170M-D3H with the same IT8628E Chip
(0008466)
ketchUP   
2017-02-09 20:44   
Me too! with GA-Z170M-DH3 (IT8628E), the "SIV" software that comes with the mobo its really buggy, still no support from Speedfan. Any idea how to stop the annoying pop up with the argus monitor trial version?
(0008487)
snifit   
2017-05-20 15:14   
I also have the issue on the H170N-Wifi gigabyte board. This board also seems to contain the IT8628E fan controller.

(0008511)
JannF   
2017-11-12 23:40   
I seem to have this ITE chip on my board too, it's a gigabyte Z170X-Gaming 7.
I can provide more info if necessary and am willing to test stuff.